Slow performance on the Students page
Incident Report for Touch-type Read and Spell
Resolved
This issue has now been resolved.
Posted Nov 11, 2021 - 09:44 GMT
Update
We are continuing to work on a fix for this issue.
Posted Nov 10, 2021 - 14:07 GMT
Identified
We are aware that some Admin and Teacher users are experiencing slow loading times for the Students page. We have identified the issue and are working on a fix.
Posted Nov 10, 2021 - 14:07 GMT